Cisco PIX515防火墙vpn无法访问内网解决方法

前天在配置公司的思科防火墙pix515时出现不能访问内网的故障,TOP 如下:
我的vpn连接设置基本上是用PDM页面上完成的,可现在在windows下使用pptp拨号可以连接并分配到VPN Pool中的地址192.168.2.1,可无法访问内部网络,也ping不通,设置如下,请各位高手帮忙解决
PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security50
hostname Pix
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
access-list outside_cryptomap_dyn_20 permit ip any 192.168.2.0 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 192.168.0.0 255.255.255.0 192.168
.2.0 255.255.255.0
access-list outside_access_in permit tcp 192.168.2.0 255.255.255.0 192.168.0.0 2
enable
pager lines 24
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 100full
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside 202.221.26.228 255.255.255.248
ip address inside 192.168.0.220 255.255.255.0
ip address dmz 172.16.0.1 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN 192.168.2.1-192.168.2.254
pdm location 192.168.0.55 255.255.255.255 inside
pdm location 192.168.2.0 255.255.255.0 outside
pdm location 192.168.2.0 255.255.255.0 inside
pdm history enable
arp timeout 14400
global (outside) 1 202.221.26.229 netmask 255.255.255.248
nat (outside) 0 192.168.2.0 255.255.255.0 outside 0 0
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 221.224.26.225 1
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.0.55 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
no sysopt route dnat
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_DES_MD5 esp-des esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_DES_MD5 mode transport
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-SHA
crypto dynamic-map outside_dyn_map 20 set security-association lifetime seconds
1800 kilobytes 4608000
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption des
isakmp policy 40 hash md5
isakmp policy 40 group 1
isakmp policy 40 lifetime 86400
vpngroup vpn address-pool VPN
vpngroup vpn dns-server 61.177.7.1 221.228.255.1
vpngroup vpn default-domain tbc
vpngroup vpn split-tunnel outside_cryptomap_dyn_20
vpngroup vpn idle-time 1800
vpngroup vpn password ********
telnet 192.168.0.55 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP client configuration address local VPN
vpdn group PPTP-VPDN-GROUP client configuration dns 61.177.7.1 221.228.255.1
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username vpnuser password ********
vpdn enable outside
username vpnuser password aHfQCIYuzZERUYTj encrypted privilege 15
vpnclient vpnuser 1 password ********
vpnclient server 221.224.26.228
vpnclient mode client-mode
terminal width 80
经过分析,原来是没有做nat (inside) 0 access-list outside_cryptomap_dyn

发表评论

电子邮件地址不会被公开。 必填项已用*标注